Reactor Dependency Convergence

Legend:
[Error]
At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 47
Number of dependencies (NOD): 524
Number of unique artifacts (NOA): 796
Number of version-conflicting artifacts (NOC): 37
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA):
[Error]
 65 %
Ready for release (100 % convergence and no SNAPSHOTS):
[Error]
 Error
You do not have 100 % convergence.

Dependencies used in modules

com.fasterxml.jackson.datatype:jackson-datatype-jsr310

[Error]
2.13.2
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    +- org.springframework.boot:spring-boot-starter-web:jar:2.6.7:compile
    |  \- org.springframework.boot:spring-boot-starter-json:jar:2.6.7:compile
    |     \- (com.fasterxml.jackson.datatype:jackson-datatype-jsr310:jar:2.13.2:compile - omitted for conflict with 2.13.4)
    +- org.springframework.boot:spring-boot-starter-actuator:jar:2.6.7:compile
    |  \- org.springframework.boot:spring-boot-actuator-autoconfigure:jar:2.6.7:compile
    |     \- (com.fasterxml.jackson.datatype:jackson-datatype-jsr310:jar:2.13.2:runtime - omitted for duplicate)
    \- org.apache.logging.log4j:log4j-kubernetes:jar:2.19.0:compile
       \- io.fabric8:kubernetes-client:jar:5.12.2:compile
          \- (com.fasterxml.jackson.datatype:jackson-datatype-jsr310:jar:2.13.2:compile - version managed from 2.13.1; omitted for conflict with 2.13.4)

2.13.4
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- com.fasterxml.jackson.datatype:jackson-datatype-jsr310:jar:2.13.4:compile

com.google.guava:guava

[Error]
11.0.2
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
       +- org.apache.flume:flume-ng-configuration:jar:1.10.1:compile
       |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
       +- org.apache.flume:flume-ng-core:jar:1.10.1:compile
       |  +- org.apache.flume:flume-ng-auth:jar:1.10.1:compile
       |  |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
       |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
       +- org.apache.flume.flume-ng-sinks:flume-hdfs-sink:jar:1.10.1:compile
       |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
       \- com.google.guava:guava:jar:11.0.2:compile

  2. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.9.0:compile
       +- org.apache.flume:flume-ng-configuration:jar:1.9.0:compile
       |  \- com.google.guava:guava:jar:11.0.2:compile
       +- org.apache.flume:flume-ng-core:jar:1.10.1:compile (version managed from 1.9.0)
       |  +- org.apache.flume:flume-ng-auth:jar:1.10.1:compile
       |  |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
       |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile (version managed from 1.9.0)
          +- org.apache.flume.flume-ng-sinks:flume-hdfs-sink:jar:1.10.1:compile
          |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
          \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)

  3. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-core:jar:1.10.1:compile
    |  +- org.apache.flume:flume-ng-configuration:jar:1.10.1:compile
    |  |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
    |  +- org.apache.flume:flume-ng-auth:jar:1.10.1:compile
    |  |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
    |  \- com.google.guava:guava:jar:11.0.2:compile
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
          +- org.apache.flume.flume-ng-sinks:flume-hdfs-sink:jar:1.10.1:compile
          |  \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)
          \- (com.google.guava:guava:jar:11.0.2:compile - omitted for duplicate)

12.0
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- io.airlift:airline:jar:0.6:test
          \- (com.google.guava:guava:jar:12.0:test - omitted for conflict with 19.0)

16.0
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- org.caffinitas.ohc:ohc-core:jar:0.4.4:test
          \- (com.google.guava:guava:jar:16.0:test - omitted for conflict with 19.0)

18.0
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- (com.google.guava:guava:jar:18.0:test - omitted for conflict with 19.0)

19.0
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- com.google.guava:guava:jar:19.0:compile

20.0
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- com.github.tomakehurst:wiremock:jar:2.26.3:test
       \- com.google.guava:guava:jar:20.0:test

25.1-android
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- com.google.inject:guice:jar:no_aop:4.2.2:test
          \- (com.google.guava:guava:jar:25.1-android:test - omitted for conflict with 20.0)

27.0.1-jre
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
       \- org.apache.curator:curator-framework:jar:5.1.0:compile
          \- org.apache.curator:curator-client:jar:5.1.0:compile
             \- (com.google.guava:guava:jar:27.0.1-jre:compile - omitted for conflict with 11.0.2)

  2. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.9.0:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile (version managed from 1.9.0)
          \- org.apache.curator:curator-framework:jar:5.1.0:compile
             \- org.apache.curator:curator-client:jar:5.1.0:compile
                \- (com.google.guava:guava:jar:27.0.1-jre:compile - omitted for conflict with 11.0.2)

  3. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
          \- org.apache.curator:curator-framework:jar:5.1.0:compile
             \- org.apache.curator:curator-client:jar:5.1.0:compile
                \- (com.google.guava:guava:jar:27.0.1-jre:compile - omitted for conflict with 11.0.2)

28.1-android
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- com.google.code.java-allocation-instrumenter:java-allocation-instrumenter:jar:3.3.0:test
       \- (com.google.guava:guava:jar:28.1-android:test - omitted for conflict with 20.0)

29.0-jre
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.zapodot:embedded-ldap-junit:jar:0.8.1:test
       \- (com.google.guava:guava:jar:29.0-jre:test - omitted for conflict with 20.0)

commons-cli:commons-cli

[Error]
1.2
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:compile
       \- (commons-cli:commons-cli:jar:1.2:compile - omitted for conflict with 1.5.0)

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:test
       \- (commons-cli:commons-cli:jar:1.2:test - omitted for conflict with 1.5.0)

1.5.0
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
       +- org.apache.flume:flume-ng-core:jar:1.10.1:compile
       |  \- (commons-cli:commons-cli:jar:1.5.0:compile - omitted for duplicate)
       \- commons-cli:commons-cli:jar:1.5.0:compile

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-core:jar:1.10.1:compile
    |  \- commons-cli:commons-cli:jar:1.5.0:compile
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
          \- (commons-cli:commons-cli:jar:1.5.0:compile - omitted for duplicate)

commons-collections:commons-collections

[Error]
3.2.1
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:compile
       \- commons-configuration:commons-configuration:jar:1.6:compile
          \- (commons-collections:commons-collections:jar:3.2.1:compile - omitted for conflict with 3.2.2)

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:test
       \- commons-configuration:commons-configuration:jar:1.6:test
          \- (commons-collections:commons-collections:jar:3.2.1:test - omitted for conflict with 3.2.2)

3.2.2
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    +- org.apache.flume:flume-ng-node:jar:1.10.1:compile
    |  \- org.apache.flume.flume-ng-channels:flume-spillable-memory-channel:jar:1.10.1:compile
    |     \- (commons-collections:commons-collections:jar:3.2.2:compile - omitted for duplicate)
    \- org.apache.flume.flume-ng-channels:flume-file-channel:jar:1.10.1:compile
       \- commons-collections:commons-collections:jar:3.2.2:compile

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
    |  \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
    |     \- org.apache.flume.flume-ng-channels:flume-spillable-memory-channel:jar:1.10.1:compile
    |        \- (commons-collections:commons-collections:jar:3.2.2:compile - omitted for duplicate)
    \- org.apache.flume.flume-ng-channels:flume-file-channel:jar:1.10.1:test (scope not updated to compile)
       \- commons-collections:commons-collections:jar:3.2.2:test

commons-httpclient:commons-httpclient

[Error]
3.0.1
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:compile
       \- commons-httpclient:commons-httpclient:jar:3.0.1:compile

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:test
       \- commons-httpclient:commons-httpclient:jar:3.0.1:test

3.1
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:compile
       \- net.java.dev.jets3t:jets3t:jar:0.6.1:compile
          \- (commons-httpclient:commons-httpclient:jar:3.1:compile - omitted for conflict with 3.0.1)

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:test
       \- net.java.dev.jets3t:jets3t:jar:0.6.1:test
          \- (commons-httpclient:commons-httpclient:jar:3.1:test - omitted for conflict with 3.0.1)

commons-lang:commons-lang

[Error]
2.4
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:compile
       \- commons-configuration:commons-configuration:jar:1.6:compile
          \- (commons-lang:commons-lang:jar:2.4:compile - omitted for conflict with 2.6)

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.hadoop:hadoop-core:jar:1.2.1:test
       \- commons-configuration:commons-configuration:jar:1.6:test
          \- (commons-lang:commons-lang:jar:2.4:test - omitted for conflict with 2.6)

2.6
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    +- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
    |  \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
    |     \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    +- org.apache.flume:flume-ng-node:jar:1.10.1:compile
    |  +- org.apache.flume:flume-ng-core:jar:1.10.1:compile
    |  |  \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    |  +- org.apache.flume.flume-ng-sinks:flume-hdfs-sink:jar:1.10.1:compile
    |  |  \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    |  +- org.apache.flume.flume-ng-channels:flume-spillable-memory-channel:jar:1.10.1:compile
    |  |  \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    |  \- org.apache.curator:curator-framework:jar:5.1.0:compile
    |     \- org.apache.curator:curator-client:jar:5.1.0:compile
    |        \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
    |           \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    \- org.apache.flume.flume-ng-channels:flume-file-channel:jar:1.10.1:compile
       \- commons-lang:commons-lang:jar:2.6:compile

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
    |  \- commons-lang:commons-lang:jar:2.6:compile
    +- org.apache.flume:flume-ng-core:jar:1.10.1:compile
    |  \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    +- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
    |  \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
    |     +- org.apache.flume.flume-ng-sinks:flume-hdfs-sink:jar:1.10.1:compile
    |     |  \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    |     +- org.apache.flume.flume-ng-channels:flume-spillable-memory-channel:jar:1.10.1:compile
    |     |  \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    |     \- org.apache.curator:curator-framework:jar:5.1.0:compile
    |        \- org.apache.curator:curator-client:jar:5.1.0:compile
    |           \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
    |              \- (commons-lang:commons-lang:jar:2.6:compile - omitted for duplicate)
    \- org.apache.flume.flume-ng-channels:flume-file-channel:jar:1.10.1:test (scope not updated to compile)
       \- (commons-lang:commons-lang:jar:2.6:test - omitted for duplicate)

io.dropwizard.metrics:metrics-core

[Error]
3.1.0
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- com.addthis.metrics:reporter-config3:jar:3.0.3:test
          \- (io.dropwizard.metrics:metrics-core:jar:3.1.0:test - omitted for conflict with 3.2.2)

3.1.5
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       +- (io.dropwizard.metrics:metrics-core:jar:3.1.5:test - omitted for conflict with 3.2.2)
       +- io.dropwizard.metrics:metrics-jvm:jar:3.1.5:test
       |  \- (io.dropwizard.metrics:metrics-core:jar:3.1.5:test - omitted for conflict with 3.2.2)
       \- io.dropwizard.metrics:metrics-logback:jar:3.1.5:test
          \- (io.dropwizard.metrics:metrics-core:jar:3.1.5:test - omitted for conflict with 3.2.2)

3.2.2
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- io.dropwizard.metrics:metrics-core:jar:3.2.2:compile

io.netty:netty-buffer

[Error]
4.1.45.Final
  1. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
          \- org.apache.curator:curator-framework:jar:5.1.0:compile
             \- org.apache.curator:curator-client:jar:5.1.0:compile
                \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
                   \- io.netty:netty-transport-native-epoll:jar:4.1.45.Final:compile
                      +- (io.netty:netty-buffer:jar:4.1.45.Final:compile - omitted for conflict with 4.1.80.Final)
                      \- io.netty:netty-transport-native-unix-common:jar:4.1.80.Final:compile
                         \- (io.netty:netty-buffer:jar:4.1.45.Final:compile - omitted for conflict with 4.1.80.Final)

4.1.68.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             +- io.netty:netty-buffer:jar:4.1.68.Final:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile
                +- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)
                +- io.netty:netty-transport:jar:4.1.80.Final:compile
                |  \- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)
                \- io.netty:netty-codec:jar:4.1.80.Final:compile
                   \- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             +- io.netty:netty-buffer:jar:4.1.68.Final:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile
                +- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)
                +- io.netty:netty-transport:jar:4.1.80.Final:compile
                |  \- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)
                \- io.netty:netty-codec:jar:4.1.80.Final:compile
                   \- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)

  3. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
       \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          \- io.netty:netty-handler:jar:4.1.80.Final:compile
             +- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)
             +- io.netty:netty-transport:jar:4.1.80.Final:compile
             |  \- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)
             \- io.netty:netty-codec:jar:4.1.80.Final:compile
                \- (io.netty:netty-buffer:jar:4.1.68.Final:compile - omitted for duplicate)

4.1.75.Final
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- io.netty:netty-handler:jar:4.1.75.Final:compile
          +- io.netty:netty-buffer:jar:4.1.75.Final:compile
          +- io.netty:netty-transport:jar:4.1.75.Final:compile
          |  \- (io.netty:netty-buffer:jar:4.1.75.Final:compile - omitted for duplicate)
          \- io.netty:netty-codec:jar:4.1.75.Final:compile
             \- (io.netty:netty-buffer:jar:4.1.75.Final:compile - omitted for duplicate)

4.1.80.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             +- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)
             +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)
             +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
             |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)
             +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)
             \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
                \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             +- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)
             +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)
             +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
             |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)
             +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)
             \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
                \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)

  3. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.0.44.Final)
          +- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
          |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
          |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
          |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
             \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)

  4. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
    |  \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
    |     \- io.netty:netty-buffer:jar:4.1.80.Final:compile
    \- io.netty:netty-all:jar:4.1.80.Final:test
       +- (io.netty:netty-buffer:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
       |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for duplicate)
       +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
       |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for duplicate)
       +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
       |  \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for duplicate)
       \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
          \- (io.netty:netty-buffer:jar:4.1.80.Final:test - omitted for duplicate)

io.netty:netty-codec

[Error]
4.1.75.Final
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- io.netty:netty-handler:jar:4.1.75.Final:compile
          \- io.netty:netty-codec:jar:4.1.75.Final:compile

4.1.80.Final
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.0.44.Final)
          \- (io.netty:netty-codec:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)

io.netty:netty-common

[Error]
4.1.45.Final
  1. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
          \- org.apache.curator:curator-framework:jar:5.1.0:compile
             \- org.apache.curator:curator-client:jar:5.1.0:compile
                \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
                   \- io.netty:netty-transport-native-epoll:jar:4.1.45.Final:compile
                      +- (io.netty:netty-common:jar:4.1.45.Final:compile - omitted for conflict with 4.1.80.Final)
                      \- io.netty:netty-transport-native-unix-common:jar:4.1.80.Final:compile
                         \- (io.netty:netty-common:jar:4.1.45.Final:compile - omitted for conflict with 4.1.80.Final)

4.1.68.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile
                +- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
                +- io.netty:netty-resolver:jar:4.1.80.Final:compile
                |  \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
                +- io.netty:netty-transport:jar:4.1.80.Final:compile
                |  \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
                \- io.netty:netty-codec:jar:4.1.80.Final:compile
                   \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile
                +- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
                +- io.netty:netty-resolver:jar:4.1.80.Final:compile
                |  \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
                +- io.netty:netty-transport:jar:4.1.80.Final:compile
                |  \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
                \- io.netty:netty-codec:jar:4.1.80.Final:compile
                   \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)

  3. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
       \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          \- io.netty:netty-handler:jar:4.1.80.Final:compile
             +- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
             +- io.netty:netty-resolver:jar:4.1.80.Final:compile
             |  \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
             +- io.netty:netty-transport:jar:4.1.80.Final:compile
             |  \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)
             \- io.netty:netty-codec:jar:4.1.80.Final:compile
                \- (io.netty:netty-common:jar:4.1.68.Final:compile - omitted for duplicate)

4.1.75.Final
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- io.netty:netty-handler:jar:4.1.75.Final:compile
          +- io.netty:netty-common:jar:4.1.75.Final:compile
          +- io.netty:netty-resolver:jar:4.1.75.Final:compile
          |  \- (io.netty:netty-common:jar:4.1.75.Final:compile - omitted for duplicate)
          +- io.netty:netty-buffer:jar:4.1.75.Final:compile
          |  \- (io.netty:netty-common:jar:4.1.75.Final:compile - omitted for duplicate)
          +- io.netty:netty-transport:jar:4.1.75.Final:compile
          |  \- (io.netty:netty-common:jar:4.1.75.Final:compile - omitted for duplicate)
          \- io.netty:netty-codec:jar:4.1.75.Final:compile
             \- (io.netty:netty-common:jar:4.1.75.Final:compile - omitted for duplicate)

4.1.80.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          +- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          |  \- io.netty:netty-buffer:jar:4.1.68.Final:compile
          |     \- io.netty:netty-common:jar:4.1.80.Final:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             +- (io.netty:netty-common:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
             +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for duplicate)
             +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
             |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for duplicate)
             +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for duplicate)
             \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
                \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for duplicate)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          +- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          |  \- io.netty:netty-buffer:jar:4.1.68.Final:compile
          |     \- io.netty:netty-common:jar:4.1.80.Final:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             +- (io.netty:netty-common:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
             +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for duplicate)
             +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
             |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for duplicate)
             +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for duplicate)
             \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
                \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for duplicate)

  3. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.0.44.Final)
          +- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
          |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
          |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
          |  \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
             \- (io.netty:netty-common:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)

  4. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
    |  \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
    |     \- io.netty:netty-buffer:jar:4.1.80.Final:compile
    |        \- io.netty:netty-common:jar:4.1.80.Final:compile
    \- io.netty:netty-all:jar:4.1.80.Final:test
       +- (io.netty:netty-common:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
       |  \- (io.netty:netty-common:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
       |  \- (io.netty:netty-common:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
       |  \- (io.netty:netty-common:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
          \- (io.netty:netty-common:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)

io.netty:netty-handler

[Error]
4.1.45.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
       \- org.apache.curator:curator-framework:jar:5.1.0:compile
          \- org.apache.curator:curator-client:jar:5.1.0:compile
             \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
                \- (io.netty:netty-handler:jar:4.1.45.Final:compile - omitted for conflict with 4.1.68.Final)

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
          \- org.apache.curator:curator-framework:jar:5.1.0:compile
             \- org.apache.curator:curator-client:jar:5.1.0:compile
                \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
                   \- (io.netty:netty-handler:jar:4.1.45.Final:compile - omitted for conflict with 4.1.80.Final)

4.1.68.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile

4.1.75.Final
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- io.netty:netty-handler:jar:4.1.75.Final:compile

4.1.80.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             \- (io.netty:netty-handler:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             \- (io.netty:netty-handler:jar:4.1.80.Final:test - omitted for conflict with 4.1.68.Final)

  3. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.0.44.Final)
          \- (io.netty:netty-handler:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)

  4. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
    |  \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
    |     \- io.netty:netty-handler:jar:4.1.80.Final:compile
    \- io.netty:netty-all:jar:4.1.80.Final:test
       \- (io.netty:netty-handler:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)

io.netty:netty-resolver

[Error]
4.1.68.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile
                \- io.netty:netty-transport:jar:4.1.80.Final:compile
                   \- (io.netty:netty-resolver:jar:4.1.68.Final:compile - omitted for duplicate)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile
                \- io.netty:netty-transport:jar:4.1.80.Final:compile
                   \- (io.netty:netty-resolver:jar:4.1.68.Final:compile - omitted for duplicate)

  3. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
       \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          \- io.netty:netty-handler:jar:4.1.80.Final:compile
             \- io.netty:netty-transport:jar:4.1.80.Final:compile
                \- (io.netty:netty-resolver:jar:4.1.68.Final:compile - omitted for duplicate)

4.1.75.Final
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- io.netty:netty-handler:jar:4.1.75.Final:compile
          +- io.netty:netty-resolver:jar:4.1.75.Final:compile
          \- io.netty:netty-transport:jar:4.1.75.Final:compile
             \- (io.netty:netty-resolver:jar:4.1.75.Final:compile - omitted for duplicate)

4.1.80.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          +- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          |  \- io.netty:netty-handler:jar:4.1.68.Final:compile
          |     \- io.netty:netty-resolver:jar:4.1.80.Final:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             \- (io.netty:netty-resolver:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          +- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          |  \- io.netty:netty-handler:jar:4.1.68.Final:compile
          |     \- io.netty:netty-resolver:jar:4.1.80.Final:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             \- (io.netty:netty-resolver:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)

  3. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.0.44.Final)
          \- (io.netty:netty-resolver:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)

  4. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
    |  \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
    |     \- io.netty:netty-handler:jar:4.1.80.Final:compile
    |        \- io.netty:netty-resolver:jar:4.1.80.Final:compile
    \- io.netty:netty-all:jar:4.1.80.Final:test
       \- (io.netty:netty-resolver:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)

io.netty:netty-transport

[Error]
4.1.45.Final
  1. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
          \- org.apache.curator:curator-framework:jar:5.1.0:compile
             \- org.apache.curator:curator-client:jar:5.1.0:compile
                \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
                   \- io.netty:netty-transport-native-epoll:jar:4.1.45.Final:compile
                      +- (io.netty:netty-transport:jar:4.1.45.Final:compile - omitted for conflict with 4.1.80.Final)
                      \- io.netty:netty-transport-native-unix-common:jar:4.1.80.Final:compile
                         \- (io.netty:netty-transport:jar:4.1.45.Final:compile - omitted for conflict with 4.1.80.Final)

4.1.68.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile
                \- io.netty:netty-codec:jar:4.1.80.Final:compile
                   \- (io.netty:netty-transport:jar:4.1.68.Final:compile - omitted for duplicate)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
             \- io.netty:netty-handler:jar:4.1.68.Final:compile
                \- io.netty:netty-codec:jar:4.1.80.Final:compile
                   \- (io.netty:netty-transport:jar:4.1.68.Final:compile - omitted for duplicate)

  3. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
       \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          \- io.netty:netty-handler:jar:4.1.80.Final:compile
             \- io.netty:netty-codec:jar:4.1.80.Final:compile
                \- (io.netty:netty-transport:jar:4.1.68.Final:compile - omitted for duplicate)

4.1.75.Final
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- io.netty:netty-handler:jar:4.1.75.Final:compile
          +- io.netty:netty-transport:jar:4.1.75.Final:compile
          \- io.netty:netty-codec:jar:4.1.75.Final:compile
             \- (io.netty:netty-transport:jar:4.1.75.Final:compile - omitted for duplicate)

4.1.80.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          +- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          |  \- io.netty:netty-handler:jar:4.1.68.Final:compile
          |     \- io.netty:netty-transport:jar:4.1.80.Final:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             +- (io.netty:netty-transport:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
             +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for duplicate)
             +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
             |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for duplicate)
             +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for duplicate)
             \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
                \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for duplicate)

  2. org.apache.logging.log4j.samples:log4j-samples-flume-remote:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          +- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
          |  \- io.netty:netty-handler:jar:4.1.68.Final:compile
          |     \- io.netty:netty-transport:jar:4.1.80.Final:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             +- (io.netty:netty-transport:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
             +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for duplicate)
             +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
             |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for duplicate)
             +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
             |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for duplicate)
             \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
                \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for duplicate)

  3. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.0.44.Final)
          +- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
          |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
          |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
          |  \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)
          \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
             \- (io.netty:netty-transport:jar:4.1.80.Final:test - omitted for conflict with 4.1.75.Final)

  4. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    +- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
    |  \- org.apache.avro:avro-ipc-netty:jar:1.11.0:compile
    |     \- io.netty:netty-handler:jar:4.1.80.Final:compile
    |        \- io.netty:netty-transport:jar:4.1.80.Final:compile
    \- io.netty:netty-all:jar:4.1.80.Final:test
       +- (io.netty:netty-transport:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
       |  \- (io.netty:netty-transport:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       +- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test
       |  \- (io.netty:netty-transport:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       +- io.netty:netty-transport-native-kqueue:jar:osx-x86_64:4.1.80.Final:test
       |  \- (io.netty:netty-transport:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)
       \- io.netty:netty-transport-native-kqueue:jar:osx-aarch_64:4.1.80.Final:test
          \- (io.netty:netty-transport:jar:4.1.80.Final:compile - scope updated from test; omitted for duplicate)

io.netty:netty-transport-native-epoll

[Error]
4.1.45.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
       \- org.apache.curator:curator-framework:jar:5.1.0:compile
          \- org.apache.curator:curator-client:jar:5.1.0:compile
             \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
                \- io.netty:netty-transport-native-epoll:jar:4.1.45.Final:compile

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.10.1:compile
       \- org.apache.flume:flume-ng-node:jar:1.10.1:compile
          \- org.apache.curator:curator-framework:jar:5.1.0:compile
             \- org.apache.curator:curator-client:jar:5.1.0:compile
                \- org.apache.zookeeper:zookeeper:jar:3.6.0:compile
                   \- io.netty:netty-transport-native-epoll:jar:4.1.45.Final:compile

4.1.80.Final
  1. org.apache.logging.log4j.samples:log4j-samples-flume-embedded:war:2.19.0
    \- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
       \- org.apache.flume:flume-ng-sdk:jar:1.10.1:compile
          \- io.netty:netty-all:jar:4.1.80.Final:test (version managed from 4.1.72.Final; scope managed from compile)
             +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
             \- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test

  2. org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0
    \- io.netty:netty-all:jar:4.1.80.Final:test
       +- io.netty:netty-transport-native-epoll:jar:linux-x86_64:4.1.80.Final:test
       \- io.netty:netty-transport-native-epoll:jar:linux-aarch_64:4.1.80.Final:test

javax.annotation:javax.annotation-api

[Error]
1.2
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.5:test
          \- (javax.annotation:javax.annotation-api:jar:1.2:test - omitted for conflict with 1.3.2)

1.3.2
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    +- org.apache.activemq:activemq-broker:jar:5.17.1:test
    |  \- javax.annotation:javax.annotation-api:jar:1.3.2:test
    \- com.google.code.java-allocation-instrumenter:java-allocation-instrumenter:jar:3.3.0:test
       \- (javax.annotation:javax.annotation-api:jar:1.3.2:test - omitted for duplicate)

javax.servlet:javax.servlet-api

[Error]
3.1.0
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- javax.servlet:javax.servlet-api:jar:3.1.0:provided

4.0.1
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.9.0:compile
       \- org.apache.flume:flume-ng-core:jar:1.10.1:compile (version managed from 1.9.0)
          \- org.eclipse.jetty:jetty-server:jar:9.4.46.v20220331:compile
             \- (javax.servlet:javax.servlet-api:jar:4.0.1:provided - version managed from 3.1.0; scope managed from compile; omitted for conflict with 3.1.0)

net.bytebuddy:byte-buddy

[Error]
1.10.10
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.zapodot:embedded-ldap-junit:jar:0.8.1:test
       \- (net.bytebuddy:byte-buddy:jar:1.10.10:test - omitted for conflict with 1.12.10)

1.12.10
  1. org.apache.logging.log4j:log4j-api:jar:2.19.0
    \- org.assertj:assertj-core:jar:3.23.1:test
       \- net.bytebuddy:byte-buddy:jar:1.12.10:test

  2. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.assertj:assertj-core:jar:3.23.1:test
       \- net.bytebuddy:byte-buddy:jar:1.12.10:test

1.12.8
  1. org.apache.logging.log4j:log4j-api:jar:2.19.0
    \- uk.org.webcompere:system-stubs-jupiter:jar:2.0.1:test
       \- org.mockito:mockito-inline:jar:3.12.4:test
          \- org.mockito:mockito-core:jar:4.4.0:test (version managed from 3.12.4)
             \- (net.bytebuddy:byte-buddy:jar:1.12.8:test - omitted for conflict with 1.12.10)

  2. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.mockito:mockito-core:jar:4.4.0:test
       \- (net.bytebuddy:byte-buddy:jar:1.12.8:test - omitted for conflict with 1.12.10)

org.apache.flume:flume-ng-configuration

[Error]
1.10.1
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.9.0:compile
       +- org.apache.flume:flume-ng-core:jar:1.10.1:compile (version managed from 1.9.0)
       |  \- (org.apache.flume:flume-ng-configuration:jar:1.10.1:compile - omitted for conflict with 1.9.0)
       +- org.apache.flume:flume-ng-node:jar:1.10.1:compile (version managed from 1.9.0)
       |  +- (org.apache.flume:flume-ng-configuration:jar:1.10.1:compile - omitted for conflict with 1.9.0)
       |  +- org.apache.flume.flume-ng-sinks:flume-hdfs-sink:jar:1.10.1:compile
       |  |  \- (org.apache.flume:flume-ng-configuration:jar:1.10.1:compile - omitted for conflict with 1.9.0)
       |  +- org.apache.flume.flume-ng-sinks:flume-irc-sink:jar:1.10.1:compile
       |  |  \- (org.apache.flume:flume-ng-configuration:jar:1.10.1:compile - omitted for conflict with 1.9.0)
       |  +- org.apache.flume.flume-ng-channels:flume-jdbc-channel:jar:1.10.1:compile
       |  |  \- (org.apache.flume:flume-ng-configuration:jar:1.10.1:compile - omitted for conflict with 1.9.0)
       |  \- org.apache.flume.flume-ng-channels:flume-spillable-memory-channel:jar:1.10.1:compile
       |     \- (org.apache.flume:flume-ng-configuration:jar:1.10.1:compile - omitted for conflict with 1.9.0)
       \- org.apache.flume.flume-ng-channels:flume-file-channel:jar:1.10.1:compile
          \- (org.apache.flume:flume-ng-configuration:jar:1.10.1:compile - omitted for conflict with 1.9.0)

1.9.0
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.9.0:compile
       \- org.apache.flume:flume-ng-configuration:jar:1.9.0:compile

org.apache.flume:flume-ng-sdk

[Error]
1.10.1
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    +- org.apache.logging.log4j:log4j-flume-ng:jar:2.19.0:compile
    |  \- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - omitted for conflict with 1.9.0)
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.9.0:compile
       +- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       +- org.apache.flume:flume-ng-configuration:jar:1.9.0:compile
       |  \- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       +- org.apache.flume:flume-ng-core:jar:1.10.1:compile (version managed from 1.9.0)
       |  +- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       |  \- org.apache.flume:flume-ng-auth:jar:1.10.1:compile
       |     \- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       +- org.apache.flume:flume-ng-node:jar:1.10.1:compile (version managed from 1.9.0)
       |  +- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       |  +- org.apache.flume.flume-ng-sinks:flume-hdfs-sink:jar:1.10.1:compile
       |  |  \- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       |  +- org.apache.flume.flume-ng-sinks:flume-irc-sink:jar:1.10.1:compile
       |  |  \- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       |  +- org.apache.flume.flume-ng-channels:flume-jdbc-channel:jar:1.10.1:compile
       |  |  \- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       |  \- org.apache.flume.flume-ng-channels:flume-spillable-memory-channel:jar:1.10.1:compile
       |     \- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)
       \- org.apache.flume.flume-ng-channels:flume-file-channel:jar:1.10.1:compile
          \- (org.apache.flume:flume-ng-sdk:jar:1.10.1:compile - version managed from 1.9.0; omitted for conflict with 1.9.0)

1.9.0
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.apache.flume:flume-ng-sdk:jar:1.9.0:compile

org.apache.httpcomponents:httpclient

[Error]
4.5.10
  1. org.apache.logging.log4j:log4j-layout-template-json:jar:2.19.0
    \- org.elasticsearch.client:elasticsearch-rest-high-level-client:jar:7.17.6:test
       \- org.elasticsearch.client:elasticsearch-rest-client:jar:7.17.6:test
          \- org.apache.httpcomponents:httpclient:jar:4.5.10:test

4.5.6
  1. org.apache.logging.log4j:log4j-layout-template-json:jar:2.19.0
    \- org.elasticsearch.client:elasticsearch-rest-high-level-client:jar:7.17.6:test
       \- org.elasticsearch.client:elasticsearch-rest-client:jar:7.17.6:test
          \- org.apache.httpcomponents:httpasyncclient:jar:4.1.4:test
             \- (org.apache.httpcomponents:httpclient:jar:4.5.6:test - omitted for conflict with 4.5.10)

org.apache.httpcomponents:httpcore

[Error]
4.4.10
  1. org.apache.logging.log4j:log4j-layout-template-json:jar:2.19.0
    \- org.elasticsearch.client:elasticsearch-rest-high-level-client:jar:7.17.6:test
       \- org.elasticsearch.client:elasticsearch-rest-client:jar:7.17.6:test
          \- org.apache.httpcomponents:httpasyncclient:jar:4.1.4:test
             \- (org.apache.httpcomponents:httpcore:jar:4.4.10:test - omitted for conflict with 4.4.12)

4.4.12
  1. org.apache.logging.log4j:log4j-layout-template-json:jar:2.19.0
    \- org.elasticsearch.client:elasticsearch-rest-high-level-client:jar:7.17.6:test
       \- org.elasticsearch.client:elasticsearch-rest-client:jar:7.17.6:test
          +- org.apache.httpcomponents:httpclient:jar:4.5.10:test
          |  \- (org.apache.httpcomponents:httpcore:jar:4.4.12:test - omitted for duplicate)
          +- org.apache.httpcomponents:httpcore:jar:4.4.12:test
          \- org.apache.httpcomponents:httpcore-nio:jar:4.4.12:test
             \- (org.apache.httpcomponents:httpcore:jar:4.4.12:test - omitted for duplicate)

org.apache.httpcomponents:httpcore-nio

[Error]
4.4.10
  1. org.apache.logging.log4j:log4j-layout-template-json:jar:2.19.0
    \- org.elasticsearch.client:elasticsearch-rest-high-level-client:jar:7.17.6:test
       \- org.elasticsearch.client:elasticsearch-rest-client:jar:7.17.6:test
          \- org.apache.httpcomponents:httpasyncclient:jar:4.1.4:test
             \- (org.apache.httpcomponents:httpcore-nio:jar:4.4.10:test - omitted for conflict with 4.4.12)

4.4.12
  1. org.apache.logging.log4j:log4j-layout-template-json:jar:2.19.0
    \- org.elasticsearch.client:elasticsearch-rest-high-level-client:jar:7.17.6:test
       \- org.elasticsearch.client:elasticsearch-rest-client:jar:7.17.6:test
          \- org.apache.httpcomponents:httpcore-nio:jar:4.4.12:test

org.apache.logging.log4j:log4j-api

[Error]
2.13.3
  1. org.apache.logging.log4j.samples:log4j-spring-cloud-config-sample-server:jar:2.19.0
    +- org.springframework.boot:spring-boot-starter-log4j2:jar:2.3.6.RELEASE:compile
    |  \- org.apache.logging.log4j:log4j-jul:jar:2.13.3:compile
    |     \- (org.apache.logging.log4j:log4j-api:jar:2.13.3:compile - omitted for duplicate)
    +- org.apache.logging.log4j:log4j-core:jar:2.19.0:compile
    |  \- (org.apache.logging.log4j:log4j-api:jar:2.13.3:compile - version managed from 2.19.0; omitted for conflict with 2.19.0)
    \- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.19.0:compile
       \- (org.apache.logging.log4j:log4j-api:jar:2.13.3:compile - version managed from 2.19.0; omitted for conflict with 2.19.0)

2.19.0
  1. org.apache.logging.log4j.samples:log4j-spring-cloud-config-sample-server:jar:2.19.0
    \- org.apache.logging.log4j:log4j-api:jar:2.19.0:compile

org.apache.logging.log4j:log4j-core

[Error]
2.13.3
  1. org.apache.logging.log4j.samples:log4j-spring-cloud-config-sample-server:jar:2.19.0
    +- org.springframework.boot:spring-boot-starter-log4j2:jar:2.3.6.RELEASE:compile
    |  \- (org.apache.logging.log4j:log4j-core:jar:2.13.3:compile - omitted for conflict with 2.19.0)
    \- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.19.0:compile
       \- (org.apache.logging.log4j:log4j-core:jar:2.13.3:runtime - version managed from 2.19.0; omitted for conflict with 2.19.0)

2.19.0
  1. org.apache.logging.log4j.samples:log4j-spring-cloud-config-sample-server:jar:2.19.0
    \- org.apache.logging.log4j:log4j-core:jar:2.19.0:compile

org.apache.logging.log4j:log4j-slf4j-impl

[Error]
2.13.3
  1. org.apache.logging.log4j.samples:log4j-spring-cloud-config-sample-server:jar:2.19.0
    \- org.springframework.boot:spring-boot-starter-log4j2:jar:2.3.6.RELEASE:compile
       \- (org.apache.logging.log4j:log4j-slf4j-impl:jar:2.13.3:compile - omitted for conflict with 2.19.0)

2.19.0
  1. org.apache.logging.log4j.samples:log4j-spring-cloud-config-sample-server:jar:2.19.0
    \- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.19.0:compile

org.apache.thrift:libthrift

[Error]
0.9.1
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- com.thinkaurelius.thrift:thrift-server:jar:0.3.7:test
          \- (org.apache.thrift:libthrift:jar:0.9.1:test - omitted for conflict with 0.9.2)

0.9.2
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    +- org.apache.cassandra:cassandra-all:jar:3.11.13:test
    |  \- org.apache.thrift:libthrift:jar:0.9.2:test
    \- org.apache.cassandra:cassandra-thrift:jar:3.11.13:test
       \- (org.apache.thrift:libthrift:jar:0.9.2:test - omitted for duplicate)

org.codehaus.mojo:animal-sniffer-annotations

[Error]
1.14
  1. org.apache.logging.log4j:log4j-api:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- com.google.inject:guice:jar:no_aop:4.2.2:test
          \- com.google.guava:guava:jar:25.1-android:test
             \- (org.codehaus.mojo:animal-sniffer-annotations:jar:1.14:test - omitted for conflict with 1.9)

1.9
  1. org.apache.logging.log4j:log4j-api:jar:2.19.0
    \- org.apache.felix:org.apache.felix.framework:jar:7.0.5:test
       \- org.codehaus.mojo:animal-sniffer-annotations:jar:1.9:test

org.codehaus.plexus:plexus-classworlds

[Error]
2.5.2
  1. org.apache.logging.log4j:log4j-api:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.5:test
          \- (org.codehaus.plexus:plexus-classworlds:jar:2.5.2:test - omitted for conflict with 2.6.0)

  2. org.apache.logging.log4j:log4j-core-java9:pom:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.5:test
          \- (org.codehaus.plexus:plexus-classworlds:jar:2.5.2:test - omitted for conflict with 2.6.0)

  3. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.5:test
          \- (org.codehaus.plexus:plexus-classworlds:jar:2.5.2:test - omitted for conflict with 2.6.0)

2.6.0
  1. org.apache.logging.log4j:log4j-api:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       +- org.apache.maven:maven-plugin-api:jar:3.8.5:test
       |  \- (org.codehaus.plexus:plexus-classworlds:jar:2.6.0:test - omitted for duplicate)
       \- org.codehaus.plexus:plexus-classworlds:jar:2.6.0:test

  2. org.apache.logging.log4j:log4j-core-java9:pom:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       +- org.apache.maven:maven-plugin-api:jar:3.8.5:test
       |  \- (org.codehaus.plexus:plexus-classworlds:jar:2.6.0:test - omitted for duplicate)
       \- org.codehaus.plexus:plexus-classworlds:jar:2.6.0:test

  3. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       +- org.apache.maven:maven-plugin-api:jar:3.8.5:test
       |  \- (org.codehaus.plexus:plexus-classworlds:jar:2.6.0:test - omitted for duplicate)
       \- org.codehaus.plexus:plexus-classworlds:jar:2.6.0:test

org.codehaus.plexus:plexus-component-annotations

[Error]
1.5.5
  1. org.apache.logging.log4j:log4j-api:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.5:test
          \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:test - omitted for conflict with 2.1.0)

  2. org.apache.logging.log4j:log4j-core-java9:pom:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.5:test
          \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:test - omitted for conflict with 2.1.0)

  3. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.5:test
          \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:test - omitted for conflict with 2.1.0)

2.1.0
  1. org.apache.logging.log4j:log4j-api:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.codehaus.plexus:plexus-component-annotations:jar:2.1.0:test

  2. org.apache.logging.log4j:log4j-core-java9:pom:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.codehaus.plexus:plexus-component-annotations:jar:2.1.0:test

  3. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- org.apache.maven:maven-core:jar:3.8.5:test
       \- org.codehaus.plexus:plexus-component-annotations:jar:2.1.0:test

org.hamcrest:hamcrest-core

[Error]
1.3
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    +- org.junit.vintage:junit-vintage-engine:jar:5.9.0:test
    |  \- junit:junit:jar:4.13.2:test
    |     \- (org.hamcrest:hamcrest-core:jar:1.3:test - omitted for duplicate)
    \- org.xmlunit:xmlunit-matchers:jar:2.9.0:test
       \- org.hamcrest:hamcrest-core:jar:1.3:test

2.2
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- net.javacrumbs.json-unit:json-unit:jar:2.35.0:test
       \- net.javacrumbs.json-unit:json-unit-core:jar:2.35.0:test
          \- (org.hamcrest:hamcrest-core:jar:2.2:test - omitted for conflict with 1.3)

org.ops4j.base:ops4j-base-store

[Error]
1.5.0
  1. org.apache.logging.log4j:log4j-osgi:jar:2.19.0
    \- org.ops4j.pax.exam:pax-exam-spi:jar:4.13.5:test
       \- org.ops4j.pax.tinybundles:tinybundles:jar:2.1.1:test
          \- (org.ops4j.base:ops4j-base-store:jar:1.5.0:test - omitted for conflict with 1.5.1)

1.5.1
  1. org.apache.logging.log4j:log4j-osgi:jar:2.19.0
    \- org.ops4j.pax.exam:pax-exam:jar:4.13.5:test
       \- org.ops4j.base:ops4j-base-store:jar:1.5.1:test

org.ow2.asm:asm

[Error]
5.0.3
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
       \- com.github.jnr:jnr-ffi:jar:2.1.7:compile
          \- org.ow2.asm:asm-tree:jar:5.0.3:compile
             \- (org.ow2.asm:asm:jar:5.0.3:compile - omitted for duplicate)

5.0.4
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    +- com.datastax.cassandra:cassandra-driver-core:jar:3.11.2:compile
    |  \- com.github.jnr:jnr-ffi:jar:2.1.7:compile
    |     \- org.ow2.asm:asm:jar:5.0.4:compile
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- (org.ow2.asm:asm:jar:5.0.4:compile - scope updated from test; omitted for duplicate)

7.0
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- com.github.tomakehurst:wiremock:jar:2.26.3:test
       \- org.ow2.asm:asm:jar:7.0:test

7.2
  1. org.apache.logging.log4j:log4j-core:jar:2.19.0
    \- com.google.code.java-allocation-instrumenter:java-allocation-instrumenter:jar:3.3.0:test
       +- (org.ow2.asm:asm:jar:7.2:test - omitted for conflict with 7.0)
       +- org.ow2.asm:asm-commons:jar:7.2:test
       |  \- (org.ow2.asm:asm:jar:7.2:test - omitted for conflict with 7.0)
       +- org.ow2.asm:asm-tree:jar:7.2:test
       |  \- (org.ow2.asm:asm:jar:7.2:test - omitted for conflict with 7.0)
       \- org.ow2.asm:asm-util:jar:7.2:test
          \- (org.ow2.asm:asm:jar:7.2:test - omitted for conflict with 7.0)

org.slf4j:slf4j-api

[Error]
1.7.25
  1. org.apache.logging.log4j:log4j-slf4j-impl:jar:2.19.0
    \- org.slf4j:slf4j-api:jar:1.7.25:compile

1.7.36
  1. org.apache.logging.log4j:log4j-slf4j-impl:jar:2.19.0
    +- org.slf4j:slf4j-ext:jar:1.7.25:compile
    |  \- (org.slf4j:slf4j-api:jar:1.7.36:compile - version managed from 1.7.25; omitted for conflict with 1.7.25)
    \- org.apache.logging.log4j:log4j-to-slf4j:jar:2.19.0:test
       \- (org.slf4j:slf4j-api:jar:1.7.36:test - version managed from 1.7.25; omitted for conflict with 1.7.25)

  2. org.apache.logging.log4j:log4j-slf4j2-impl:jar:2.19.0
    +- org.slf4j:slf4j-ext:jar:2.0.0:compile
    |  \- (org.slf4j:slf4j-api:jar:1.7.36:compile - version managed from 2.0.0; omitted for conflict with 2.0.0)
    \- org.apache.logging.log4j:log4j-to-slf4j:jar:2.19.0:test
       \- (org.slf4j:slf4j-api:jar:1.7.36:test - version managed from 2.0.0; omitted for conflict with 2.0.0)

2.0.0
  1. org.apache.logging.log4j:log4j-slf4j2-impl:jar:2.19.0
    \- org.slf4j:slf4j-api:jar:2.0.0:compile

org.springframework:spring-beans

[Error]
5.3.19
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.springframework.boot:spring-boot-starter-web:jar:2.6.7:compile
       \- org.springframework:spring-webmvc:jar:5.3.19:compile
          \- (org.springframework:spring-beans:jar:5.3.19:compile - omitted for conflict with 5.3.20)

5.3.20
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    +- org.springframework.boot:spring-boot-starter-web:jar:2.6.7:compile
    |  +- org.springframework:spring-web:jar:5.3.20:compile
    |  |  \- org.springframework:spring-beans:jar:5.3.20:compile
    |  \- org.springframework:spring-webmvc:jar:5.3.19:compile
    |     +- org.springframework:spring-aop:jar:5.3.20:compile
    |     |  \- (org.springframework:spring-beans:jar:5.3.20:compile - omitted for duplicate)
    |     \- org.springframework:spring-context:jar:5.3.20:compile
    |        \- (org.springframework:spring-beans:jar:5.3.20:compile - omitted for duplicate)
    +- org.springframework.cloud:spring-cloud-starter-bus-amqp:jar:3.0.3:compile
    |  \- org.springframework.cloud:spring-cloud-bus:jar:3.0.3:compile
    |     \- org.springframework.integration:spring-integration-core:jar:5.5.11:compile
    |        +- org.springframework:spring-messaging:jar:5.3.20:compile
    |        |  \- (org.springframework:spring-beans:jar:5.3.20:compile - omitted for duplicate)
    |        \- org.springframework:spring-tx:jar:5.3.20:compile (version managed from 5.3.19)
    |           \- (org.springframework:spring-beans:jar:5.3.20:compile - omitted for duplicate)
    \- org.apache.logging.log4j:log4j-spring-cloud-config-client:jar:2.19.0:compile
       \- org.apache.logging.log4j:log4j-spring-boot:jar:2.17.2:compile (version managed from 2.19.0)
          \- org.springframework:spring-context-support:jar:5.3.20:compile (version managed from 5.3.15)
             \- (org.springframework:spring-beans:jar:5.3.20:compile - omitted for duplicate)

org.springframework:spring-core

[Error]
5.3.19
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    +- org.springframework.boot:spring-boot-starter-web:jar:2.6.7:compile
    |  \- org.springframework:spring-webmvc:jar:5.3.19:compile
    |     \- (org.springframework:spring-core:jar:5.3.19:compile - omitted for duplicate)
    +- org.springframework.cloud:spring-cloud-starter-bus-amqp:jar:3.0.3:compile
    |  \- org.springframework.cloud:spring-cloud-starter-stream-rabbit:jar:3.1.4:compile (version managed from 3.1.3)
    |     \- org.springframework.cloud:spring-cloud-stream-binder-rabbit:jar:3.1.4:compile
    |        \- org.springframework.boot:spring-boot-starter-amqp:jar:2.6.7:compile
    |           \- org.springframework.amqp:spring-rabbit:jar:2.4.4:compile (version managed from 2.3.16)
    |              \- org.springframework.amqp:spring-amqp:jar:2.4.4:compile
    |                 \- (org.springframework:spring-core:jar:5.3.19:compile - omitted for duplicate)
    +- org.springframework.boot:spring-boot-starter-test:jar:2.6.7:test
    |  \- (org.springframework:spring-core:jar:5.3.19:compile - scope updated from test; omitted for duplicate)
    \- org.springframework.boot:spring-boot-starter:jar:2.6.7:compile
       +- org.springframework.boot:spring-boot:jar:2.6.7:compile (version managed from 2.5.7)
       |  \- (org.springframework:spring-core:jar:5.3.19:compile - omitted for duplicate)
       \- org.springframework:spring-core:jar:5.3.19:compile

5.3.20
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    +- org.springframework.boot:spring-boot-starter-web:jar:2.6.7:compile
    |  +- org.springframework:spring-web:jar:5.3.20:compile
    |  |  +- org.springframework:spring-beans:jar:5.3.20:compile
    |  |  |  \- (org.springframework:spring-core:jar:5.3.20:compile - omitted for conflict with 5.3.20)
    |  |  \- (org.springframework:spring-core:jar:5.3.20:compile - omitted for conflict with 5.3.20)
    |  \- org.springframework:spring-webmvc:jar:5.3.19:compile
    |     +- org.springframework:spring-aop:jar:5.3.20:compile
    |     |  \- (org.springframework:spring-core:jar:5.3.20:compile - omitted for conflict with 5.3.20)
    |     +- org.springframework:spring-context:jar:5.3.20:compile
    |     |  \- (org.springframework:spring-core:jar:5.3.20:compile - omitted for conflict with 5.3.20)
    |     \- org.springframework:spring-expression:jar:5.3.20:compile
    |        \- (org.springframework:spring-core:jar:5.3.20:compile - omitted for conflict with 5.3.20)
    +- org.springframework.cloud:spring-cloud-starter-bus-amqp:jar:3.0.3:compile
    |  \- org.springframework.cloud:spring-cloud-bus:jar:3.0.3:compile
    |     \- org.springframework.integration:spring-integration-core:jar:5.5.11:compile
    |        +- org.springframework:spring-messaging:jar:5.3.20:compile
    |        |  \- (org.springframework:spring-core:jar:5.3.20:compile - omitted for conflict with 5.3.20)
    |        \- org.springframework:spring-tx:jar:5.3.20:compile (version managed from 5.3.19)
    |           \- (org.springframework:spring-core:jar:5.3.20:compile - omitted for conflict with 5.3.20)
    +- org.springframework:spring-test:jar:5.3.20:test
    |  \- (org.springframework:spring-core:jar:5.3.20:compile - scope updated from test; omitted for duplicate)
    \- org.apache.logging.log4j:log4j-spring-cloud-config-client:jar:2.19.0:compile
       \- org.apache.logging.log4j:log4j-spring-boot:jar:2.17.2:compile (version managed from 2.19.0)
          \- org.springframework:spring-context-support:jar:5.3.20:compile (version managed from 5.3.15)
             \- (org.springframework:spring-core:jar:5.3.20:compile - omitted for duplicate)

5.3.9
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.springframework.cloud:spring-cloud-starter-bus-amqp:jar:3.0.3:compile
       \- org.springframework.cloud:spring-cloud-starter-stream-rabbit:jar:3.1.4:compile (version managed from 3.1.3)
          \- org.springframework.cloud:spring-cloud-stream-binder-rabbit:jar:3.1.4:compile
             \- org.springframework.cloud:spring-cloud-stream:jar:3.1.4:compile
                \- org.springframework.cloud:spring-cloud-function-context:jar:3.1.4:compile
                   \- org.springframework.cloud:spring-cloud-function-core:jar:3.1.4:compile
                      \- (org.springframework:spring-core:jar:5.3.9:compile - omitted for conflict with 5.3.20)

org.xerial.snappy:snappy-java

[Error]
1.1.7.2
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.apache.kafka:kafka-clients:jar:2.2.0:compile
       \- org.xerial.snappy:snappy-java:jar:1.1.7.2:compile

1.1.8.4
  1. org.apache.logging.log4j.samples:sample-app:jar:2.19.0
    \- org.apache.flume:flume-ng-embedded-agent:jar:1.9.0:compile
       \- org.apache.flume.flume-ng-channels:flume-file-channel:jar:1.10.1:compile
          \- (org.xerial.snappy:snappy-java:jar:1.1.8.4:compile - omitted for conflict with 1.0.4.1)

org.yaml:snakeyaml

[Error]
1.12
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- com.addthis.metrics:reporter-config3:jar:3.0.3:test
          +- com.addthis.metrics:reporter-config-base:jar:3.0.3:test
          |  \- (org.yaml:snakeyaml:jar:1.12:test - omitted for conflict with 1.26)
          \- (org.yaml:snakeyaml:jar:1.12:test - omitted for conflict with 1.26)

1.26
  1. org.apache.logging.log4j:log4j-cassandra:jar:2.19.0
    \- org.apache.cassandra:cassandra-all:jar:3.11.13:test
       \- org.yaml:snakeyaml:jar:1.26:test

  2. org.apache.logging.log4j:log4j-layout-template-json:jar:2.19.0
    \- org.elasticsearch.client:elasticsearch-rest-high-level-client:jar:7.17.6:test
       \- org.elasticsearch:elasticsearch:jar:7.17.6:test
          \- org.elasticsearch:elasticsearch-x-content:jar:7.17.6:test
             \- org.yaml:snakeyaml:jar:1.26:test

1.31
  1. org.apache.logging.log4j:log4j-layout-template-json:jar:2.19.0
    \- org.elasticsearch.client:elasticsearch-rest-high-level-client:jar:7.17.6:test
       \- org.elasticsearch:elasticsearch:jar:7.17.6:test
          \- org.elasticsearch:elasticsearch-x-content:jar:7.17.6:test
             \- com.fasterxml.jackson.dataformat:jackson-dataformat-yaml:jar:2.13.4:test (version managed from 2.10.4)
                \- (org.yaml:snakeyaml:jar:1.31:test - omitted for conflict with 1.26)